• 1288
  • 0
  • Адаптировал: irbees2008
  • Уровень сложности исполнения: это делается простым копированием и нажиманием кнопки

Продолжение предыдущей темы .Там мы использовали для ограничения html5 параметр minlength,но это работает только в новых версиях браузеров,старые браузеры не поддерживают параметры html5.Пришлось порыскать по инету и решил использовать jquery плагин jquery.validate.и сейчас разберем как его подключить для нашего случая.
И так приступим
1.Вы можете скачать скрипт и подключить со своего сайта,ну а я подключил с хранилища

Код:
<script src="http://jqueryvalidation.org/files/dist/jquery.validate.min.js"></script>
обязательно наличие подключения jquery .
2.Вот наш скрипт который будет проверять поле,и выводить сообщение если количество символов меньше заданного ,унас это 200 символов.
Код:
<script>$().ready(function(){
$("#postForm").validate({
rules : {
ng_news_content : { minlength: 200},
},
messages : {
ng_news_content : {
minlength : "Введите не менее, чем 200 символа.",
},
}
});
});</script>
3.Вот и все ,изменить колличество легко ,измените 200 на свое колличество.

Можешь почитать и вот эту статейку "HTML тег br /"

mistakes

Это тоже интересно

Уважаемый посетитель, Вы зашли на сайт как незарегистрированный пользователь.
Мы рекомендуем Вам зарегистрироваться либо войти на сайт под своим именем.

Ваше мнение

Ваше отношение к TWIG
Результаты

Облако тегов

Anything in here will be replaced on browsers that support the canvas element